x

How do I set a condition filter to ignore certain wait types?

I keep getting "Top SQL Exceeded Max Runtime" alerts for service broker stored procedures waiting on BROKER_RECEIVE_WAITFOR waits. The Condition doesn't seem to allow a filter based on wait type as far as I can tell.

How do we fix this other than simply filtering on said procedure (because I would still like to know if it takes a long time when it actually has some work to do).

avatar image By Robert L Davis 0 asked Jan 08, 2016 at 03:35 PM
more ▼
(comments are locked)
10|5000 characters needed characters left

2 answers: sort voted first

Hello, SQLSoldeir.

You can place a 'Conditions Settings' filter on the 'SQL Server: Top SQL: Duration Threshold Max' condition. More information on the 'Conditions Settings' filter can be located here: http://www.sqlsentry.com/help/ug/#Condition%20Settings.html

Please see the following screenshot for more details:alt text

Regards,

Jim

ss-for-ah.jpg (59.2 kB)
avatar image By James Holden ♦ 1.6k answered Jan 08, 2016 at 08:30 PM
more ▼
(comments are locked)
avatar image Robert L Davis Jan 08, 2016 at 08:45 PM

Thanks for responding James. I went there, but I do not see any option to use wait type as a filter. Am I missing something?

10|5000 characters needed characters left

Robert,

Can you send this inquiry to support here and include a reference to this post?

Please also attach the Top SQL alert.

Thanks,

Suril

avatar image By sjasani ♦♦ 751 answered Jan 08, 2016 at 09:53 PM
more ▼
(comments are locked)
10|5000 characters needed characters left

This site is moving!

Our Q and A site has moved! Please visit our new Q and A site at support.sentryone.com to submit all new questions and to revisit our most-viewed and up-voted articles. For your convenience, this web page will be available in read-only mode for another two weeks.

Follow this question

Topics:

x29

asked: Jan 08, 2016 at 03:35 PM

Seen: 123 times

Last Updated: Jan 08, 2016 at 09:53 PM

Related Questions